summaryrefslogtreecommitdiffstats
path: root/kmilo/asus/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kmilo/asus/CMakeLists.txt')
-rw-r--r--kmilo/asus/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/kmilo/asus/CMakeLists.txt b/kmilo/asus/CMakeLists.txt
new file mode 100644
index 0000000..377e9e5
--- /dev/null
+++ b/kmilo/asus/CMakeLists.txt
@@ -0,0 +1,41 @@
+#################################################
+#
+# (C) 2012 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/kmilo/kmilod
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${CMAKE_BINARY_DIR}/kmilo/kmilod
+)
+
+
+##### kmilo_asus (kpart) ########################
+
+tde_add_kpart( kmilo_asus AUTOMOC
+ SOURCES asus.cpp
+ LINK kio-shared kmilo-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES kmilo_asus.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/kmilo
+)
+