summaryrefslogtreecommitdiffstats
path: root/kmilo/powerbook2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kmilo/powerbook2/Makefile.am')
-rw-r--r--kmilo/powerbook2/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/kmilo/powerbook2/Makefile.am b/kmilo/powerbook2/Makefile.am
new file mode 100644
index 0000000..5c3f467
--- /dev/null
+++ b/kmilo/powerbook2/Makefile.am
@@ -0,0 +1,34 @@
+# This file is part of the KDE project
+# Copyright (C) 2003 George Staikos <staikos@kde.org>
+
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+
+# You should have received a copy of the GNU Library General Public License
+# along with this library; see the file COPYING.LIB. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+
+INCLUDES=-I$(srcdir)/../kmilod $(all_includes)
+
+kde_module_LTLIBRARIES = kmilo_powerbook.la
+
+kmilo_powerbook_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+kmilo_powerbook_la_LIBADD = ../kmilod/libkmilo.la $(LIB_KIO) $(KEYBOARD_LIBS)
+kmilo_powerbook_la_SOURCES = pb_monitor.cpp
+METASOURCES = AUTO
+
+noinst_HEADERS = pb_monitor.h
+
+services_DATA = kmilo_powerbook.desktop
+servicesdir = $(kde_servicesdir)/kmilo
+
+messages:
+ $(XGETTEXT) $(kmilo_powerbook_la_SOURCES) -o $(podir)/kmilo_powerbook.pot