summaryrefslogtreecommitdiffstats
path: root/kmilo/thinkpad/kcmthinkpad/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kmilo/thinkpad/kcmthinkpad/Makefile.am')
-rw-r--r--kmilo/thinkpad/kcmthinkpad/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kmilo/thinkpad/kcmthinkpad/Makefile.am b/kmilo/thinkpad/kcmthinkpad/Makefile.am
new file mode 100644
index 0000000..4e70c40
--- /dev/null
+++ b/kmilo/thinkpad/kcmthinkpad/Makefile.am
@@ -0,0 +1,15 @@
+kde_module_LTLIBRARIES = kcm_thinkpad.la
+
+kcm_thinkpad_la_SOURCES = kcmthinkpad_general.ui main.cpp
+
+kcm_thinkpad_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+kcm_thinkpad_la_LIBADD = $(LIB_KIO)
+
+INCLUDES= $(all_includes) -DKDE_BINDIR="\"$(bindir)\""
+
+kcm_thinkpad_la_METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmthinkpad.pot
+
+xdg_apps_DATA = thinkpad.desktop