summaryrefslogtreecommitdiffstats
path: root/ktimer/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ktimer/Makefile.am')
-rw-r--r--ktimer/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/ktimer/Makefile.am b/ktimer/Makefile.am
new file mode 100644
index 0000000..35d6283
--- /dev/null
+++ b/ktimer/Makefile.am
@@ -0,0 +1,24 @@
+INCLUDES = $(all_includes)
+AM_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+LDADD = $(LIB_KDEUI) $(LIB_KFILE)
+
+bin_PROGRAMS = ktimer
+
+METASOURCES = AUTO
+
+ktimer_SOURCES = main.cpp ktimer.cpp prefwidget.ui
+# ktimer.cpp pref.cpp
+noinst_HEADERS = ktimer.h
+
+KDE_ICON = ktimer
+
+xdg_apps_DATA = ktimer.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/ktimer.pot
+
+
+srcdoc:
+ kdoc -a -p -H -d $$HOME/web/src/ktimer ktimer *.h -lkdecore -lkdeui -lqt
+
+