summaryrefslogtreecommitdiffstats
path: root/kwallet/konfigurator/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kwallet/konfigurator/Makefile.am')
-rw-r--r--kwallet/konfigurator/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kwallet/konfigurator/Makefile.am b/kwallet/konfigurator/Makefile.am
new file mode 100644
index 0000000..fab7551
--- /dev/null
+++ b/kwallet/konfigurator/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kcm_kwallet.la
+kcm_kwallet_la_SOURCES = walletconfigwidget.ui konfigurator.cpp
+kcm_kwallet_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_kwallet_la_LIBADD = $(LIB_KDEUI) -lkwalletclient
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmkwallet.pot
+
+xdg_apps_DATA = kwalletconfig.desktop
+
+kde_services_DATA = kwallet_config.desktop kwalletmanager_show.desktop
+