summaryrefslogtreecommitdiffstats
path: root/tdefilereplace/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdefilereplace/CMakeLists.txt')
-rw-r--r--tdefilereplace/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/tdefilereplace/CMakeLists.txt b/tdefilereplace/CMakeLists.txt
index 621c0e0..15c70a1 100644
--- a/tdefilereplace/CMakeLists.txt
+++ b/tdefilereplace/CMakeLists.txt
@@ -26,8 +26,15 @@ link_directories(
##### other data ################################
tde_install_icons( )
-install( FILES tdefilereplace.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES tdefilereplacepart.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE tdefilereplace.desktop
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdefilereplace-desktops
+)
+tde_create_translated_desktop(
+ SOURCE tdefilereplacepart.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdefilereplace-desktops
+)
install( FILES tdefilereplacepartui.rc DESTINATION ${DATA_INSTALL_DIR}/tdefilereplacepart )
install( FILES tdefilereplaceui.rc DESTINATION ${DATA_INSTALL_DIR}/tdefilereplace )