summaryrefslogtreecommitdiffstats
path: root/tdefilereplace/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdefilereplace/Makefile.am')
-rw-r--r--tdefilereplace/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/tdefilereplace/Makefile.am b/tdefilereplace/Makefile.am
new file mode 100644
index 0000000..f1c603b
--- /dev/null
+++ b/tdefilereplace/Makefile.am
@@ -0,0 +1,43 @@
+## Makefile.am for tdefilereplace
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# this has all of the subdirectories that make will recurse into. if
+# there are none, comment this out
+SUBDIRS = toolbar
+
+# these are the headers for your project
+noinst_HEADERS = kaddstringdlg.h tdefilereplaceiface.h tdefilereplacelib.h \
+ knewprojectdlg.h tdefilereplaceview.h koptionsdlg.h report.h commandengine.h \
+ configurationclasses.h tdefilereplace.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = libtdefilereplacepart.la
+libtdefilereplacepart_la_SOURCES = tdefilereplacepart.cpp tdefilereplaceview.cpp \
+ tdefilereplaceviewwdg.ui kaddstringdlg.cpp kaddstringdlgs.ui knewprojectdlg.cpp \
+ knewprojectdlgs.ui koptionsdlg.cpp koptionsdlgs.ui tdefilereplacelib.cpp report.cpp \
+ commandengine.cpp configurationclasses.cpp
+
+libtdefilereplacepart_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries) -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -ltdeio -ltdeparts -lDCOP
+libtdefilereplacepart_la_LIBADD = $(LIB_TDEFILE) $(LIB_TDEPARTS) $(LIB_TDEHTML)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/tdefilereplace.pot
+
+KDE_ICON = AUTO
+kde_services_DATA = tdefilereplacepart.desktop
+xdg_apps_DATA = tdefilereplace.desktop
+
+# this is where the XML-GUI resource file goes
+partrcdir = $(kde_datadir)/tdefilereplacepart
+partrc_DATA = tdefilereplacepartui.rc
+
+shellrcdir = $(kde_datadir)/tdefilereplace
+shellrc_DATA = tdefilereplaceui.rc
+bin_PROGRAMS = tdefilereplace
+tdefilereplace_LDFLAGS = $(KDE_RPATH) $(all_libraries) -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -ltdeio -ltdeparts -lDCOP
+tdefilereplace_LDADD = $(LIB_TDEPARTS)
+tdefilereplace_SOURCES = tdefilereplace.cpp main.cpp