summaryrefslogtreecommitdiffstats
path: root/tdelirc/tdelirc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdelirc/tdelirc/Makefile.am')
-rw-r--r--tdelirc/tdelirc/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/tdelirc/tdelirc/Makefile.am b/tdelirc/tdelirc/Makefile.am
new file mode 100644
index 0000000..e488f85
--- /dev/null
+++ b/tdelirc/tdelirc/Makefile.am
@@ -0,0 +1,45 @@
+####### tdevelop will overwrite this part!!! (begin)##########
+noinst_LTLIBRARIES = libtdelirc.la
+
+noinst_HEADERS = iraction.h arguments.h iractions.h prototype.h modes.h mode.h profileserver.h remoteserver.h
+
+libtdelirc_la_SOURCES = iraction.cpp arguments.cpp iractions.cpp prototype.cpp modes.cpp mode.cpp profileserver.cpp remoteserver.cpp
+libtdelirc_la_LIBADD = $(LIB_QT) $(LIB_TDECORE) $(LIB_TDEUI) $(LIBSOCKET)
+
+####### tdevelop will overwrite this part!!! (end)############
+# These paths are TDE specific. Use them:
+# kde_appsdir Where your application's menu entry (.desktop) should go to.
+# kde_icondir Where your icon should go to - better use KDE_ICON.
+# kde_sounddir Where your sounds should go to.
+# kde_htmldir Where your docs should go to. (contains lang subdirs)
+# kde_datadir Where you install application data. (Use a subdir)
+# kde_locale Where translation files should go to. (contains lang subdirs)
+# kde_cgidir Where cgi-bin executables should go to.
+# kde_confdir Where config files should go to (system-wide ones with default values).
+# kde_mimedir Where mimetypes .desktop files should go to.
+# kde_servicesdir Where services .desktop files should go to.
+# kde_servicetypesdir Where servicetypes .desktop files should go to.
+# kde_toolbardir Where general toolbar icons should go to (deprecated, use KDE_ICON).
+# kde_wallpaperdir Where general wallpapers should go to.
+# kde_irkicksdir Where irkicks for the "New" menu (Konqueror/KDesktop) should go to.
+# kde_bindir Where executables should go to. Use bin_PROGRAMS or bin_SCRIPTS.
+# kde_libdir Where shared libraries should go to. Use lib_LTLIBRARIES.
+# kde_moduledir Where modules (e.g. parts) should go to. Use kde_module_LTLIBRARIES.
+# kde_styledir Where Qt/TDE widget styles should go to (new in KDE 3).
+# kde_designerdir Where Qt Designer plugins should go to (new in KDE 3).
+
+# set the include path for X, qt and TDE
+INCLUDES = $(all_includes)
+
+METASOURCES = AUTO
+
+# the library search path.
+libtdelirc_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+
+# Uncomment the following two lines if you add a ui.rc file for your application to make use of
+# KDE´s XML GUI builing
+#rcdir = $(kde_datadir)/irkick
+#rc_DATA = irkickui.rc
+
+messages:
+ $(XGETTEXT) *.cpp *.h -o $(podir)/tdelirc.pot