summaryrefslogtreecommitdiffstats
path: root/parts/tipofday/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit114a878c64ce6f8223cfd22d76a20eb16d177e5e (patch)
treeacaf47eb0fa12142d3896416a69e74cbf5a72242 /parts/tipofday/Makefile.am
downloadtdevelop-114a878c64ce6f8223cfd22d76a20eb16d177e5e.tar.gz
tdevelop-114a878c64ce6f8223cfd22d76a20eb16d177e5e.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdevelop@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'parts/tipofday/Makefile.am')
-rw-r--r--parts/tipofday/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/parts/tipofday/Makefile.am b/parts/tipofday/Makefile.am
new file mode 100644
index 00000000..14e3a349
--- /dev/null
+++ b/parts/tipofday/Makefile.am
@@ -0,0 +1,24 @@
+INCLUDES = -I$(top_srcdir)/lib/interfaces -I$(top_srcdir)/lib/util $(all_includes)
+
+kde_module_LTLIBRARIES = libkdevtipofday.la
+libkdevtipofday_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkdevtipofday_la_LIBADD = $(top_builddir)/lib/libkdevelop.la
+
+libkdevtipofday_la_SOURCES = tipofday_part.cpp
+
+METASOURCES = AUTO
+KDE_ICON = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = kdevtipofday.desktop
+
+tip_DATA = tips
+tipdir = $(kde_datadir)/kdevtipofday
+
+rc_DATA = kdevpart_tipofday.rc
+rcdir = $(kde_datadir)/kdevtipofday
+
+messages: rc.cpp
+ $(PREPARETIPS) > tips.cc
+ $(XGETTEXT) *.cpp *.h tips.cc -o $(podir)/kdevtipofday.pot
+ rm -f tips.cc