summaryrefslogtreecommitdiffstats
path: root/src/profiles/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-29 22:43:34 +0200
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-08-01 17:56:29 +0900
commit96fa25303818e6107b72ba624659004751d45ad1 (patch)
tree89a7233f17e403e6b635d2ce7155d5f77a98d3d8 /src/profiles/CMakeLists.txt
parent3248c8c2f99f71bb2ca5972828754fdabacd7c90 (diff)
downloadtdevelop-96fa25303818e6107b72ba624659004751d45ad1.tar.gz
tdevelop-96fa25303818e6107b72ba624659004751d45ad1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit fe44776673b28ca94338f23d8e7ac71593fa88ba)
Diffstat (limited to 'src/profiles/CMakeLists.txt')
-rw-r--r--src/profiles/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/profiles/CMakeLists.txt b/src/profiles/CMakeLists.txt
index 5d886c88..7b30a7ff 100644
--- a/src/profiles/CMakeLists.txt
+++ b/src/profiles/CMakeLists.txt
@@ -12,4 +12,8 @@
add_subdirectory( IDE )
add_subdirectory( KDevAssistant )
-install( FILES profile.config DESTINATION ${DATA_INSTALL_DIR}/tdevelop/profiles )
+tde_create_translated_desktop(
+ SOURCE profile.config
+ DESTINATION ${DATA_INSTALL_DIR}/tdevelop/profiles
+ PO_DIR tdevelop-desktops
+)