summaryrefslogtreecommitdiffstats
path: root/src/profiles/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-29 22:43:34 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-30 16:00:07 +0200
commitfe44776673b28ca94338f23d8e7ac71593fa88ba (patch)
treeb900146c853acbd44900bfb77a35a1af3c77aa5d /src/profiles/CMakeLists.txt
parentc0b663c4c873df495743600b8f703744420eddfa (diff)
downloadtdevelop-fe44776673b28ca94338f23d8e7ac71593fa88ba.tar.gz
tdevelop-fe44776673b28ca94338f23d8e7ac71593fa88ba.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'src/profiles/CMakeLists.txt')
-rw-r--r--src/profiles/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/profiles/CMakeLists.txt b/src/profiles/CMakeLists.txt
index 5d886c88..7b30a7ff 100644
--- a/src/profiles/CMakeLists.txt
+++ b/src/profiles/CMakeLists.txt
@@ -12,4 +12,8 @@
add_subdirectory( IDE )
add_subdirectory( KDevAssistant )
-install( FILES profile.config DESTINATION ${DATA_INSTALL_DIR}/tdevelop/profiles )
+tde_create_translated_desktop(
+ SOURCE profile.config
+ DESTINATION ${DATA_INSTALL_DIR}/tdevelop/profiles
+ PO_DIR tdevelop-desktops
+)