summaryrefslogtreecommitdiffstats
path: root/src/tdeconf_update/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:06:29 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:06:29 -0600
commitc0b24fe164924298d7e6ae33964b3c65fadbcba3 (patch)
tree2ba50375d78b077b266b224e4413150ef3e60a15 /src/tdeconf_update/Makefile.am
parent33d15e862e09fbcbb05e209f832414bd8a01291e (diff)
downloadtdevelop-c0b24fe164924298d7e6ae33964b3c65fadbcba3.tar.gz
tdevelop-c0b24fe164924298d7e6ae33964b3c65fadbcba3.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'src/tdeconf_update/Makefile.am')
-rw-r--r--src/tdeconf_update/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/tdeconf_update/Makefile.am b/src/tdeconf_update/Makefile.am
new file mode 100644
index 00000000..d256951b
--- /dev/null
+++ b/src/tdeconf_update/Makefile.am
@@ -0,0 +1,18 @@
+AM_CPPFLAGS = -DKDE_NO_COMPAT -DQT_NO_COMPAT $(all_includes)
+
+update_DATA = kdev-gen-settings.upd
+updatedir = $(kde_datadir)/tdeconf_update
+
+# The Qt app cannot go into kde_datadir, that is not portable.
+# install to kde_bindir/tdeconf_update_bin instead.
+# KDE 3.2 will allow tdeconf_update scripts to run directly from there,
+# but for us that's too late. Use the .sh script as a workaround.
+tdeconf_PROGRAMS = kdev-gen-settings-tdeconf_update
+tdeconfdir = $(libdir)/tdeconf_update_bin
+
+kdev_gen_settings_tdeconf_update_SOURCES = kdev-gen-settings-tdeconf_update.cpp
+kdev_gen_settings_tdeconf_update_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+kdev_gen_settings_tdeconf_update_LDADD = $(LIB_QT)
+
+# vim: set noet:
+