summaryrefslogtreecommitdiffstats
path: root/vcs/subversion/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-29 22:43:34 +0200
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-08-01 17:56:29 +0900
commit96fa25303818e6107b72ba624659004751d45ad1 (patch)
tree89a7233f17e403e6b635d2ce7155d5f77a98d3d8 /vcs/subversion/CMakeLists.txt
parent3248c8c2f99f71bb2ca5972828754fdabacd7c90 (diff)
downloadtdevelop-96fa25303818e6107b72ba624659004751d45ad1.tar.gz
tdevelop-96fa25303818e6107b72ba624659004751d45ad1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit fe44776673b28ca94338f23d8e7ac71593fa88ba)
Diffstat (limited to 'vcs/subversion/CMakeLists.txt')
-rw-r--r--vcs/subversion/CMakeLists.txt15
1 files changed, 10 insertions, 5 deletions
diff --git a/vcs/subversion/CMakeLists.txt b/vcs/subversion/CMakeLists.txt
index fb51fe3d..87fdf293 100644
--- a/vcs/subversion/CMakeLists.txt
+++ b/vcs/subversion/CMakeLists.txt
@@ -30,15 +30,20 @@ link_directories(
##### other data ################################
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
kdevsubversion.desktop kdevsvn+file.protocol
kdevsvn+http.protocol kdevsvn+https.protocol
kdevsvn+ssh.protocol kdevsvn+svn.protocol
- DESTINATION ${SERVICES_INSTALL_DIR} )
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR tdevelop-desktops
+)
-install( FILES
- kdevsvnd.desktop
- DESTINATION ${SERVICES_INSTALL_DIR}/kded )
+tde_create_translated_desktop(
+ SOURCE kdevsvnd.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/kded
+ PO_DIR tdevelop-desktops
+)
##### libkdevsubversion (module) ################