summaryrefslogtreecommitdiffstats
path: root/buildtools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'buildtools/Makefile.am')
-rw-r--r--buildtools/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/buildtools/Makefile.am b/buildtools/Makefile.am
new file mode 100644
index 00000000..1c61d027
--- /dev/null
+++ b/buildtools/Makefile.am
@@ -0,0 +1,48 @@
+##
+## Do NOT remove the comments that start with "kdevelop:"
+## They are actually directives to the kdevelop plugin system
+##
+## The include_xxxx variables are controlled by configure.in.in
+##
+
+#kdevelop: ADA_BUILDTOOL = ada
+if include_ada
+ADA_BUILDTOOL = ada
+endif
+
+#kdevelop: ANT_BUILDTOOL = ant
+if include_ant
+ANT_BUILDTOOL = ant
+endif
+
+#kdevelop: AUTOTOOLS_BUILDTOOL = autotools
+if include_autoproject
+AUTOTOOLS_BUILDTOOL = autotools
+endif
+
+#kdevelop: CUSTOMMAKEFILES_BUILDTOOL = custommakefiles
+if include_customproject
+CUSTOMMAKEFILES_BUILDTOOL = custommakefiles
+endif
+
+#kdevelop: PASCAL_BUILDTOOL = pascal
+if include_pascal
+PASCAL_BUILDTOOL = pascal
+endif
+
+#kdevelop: QMAKE_BUILDTOOL = qmake
+if include_trollproject
+QMAKE_BUILDTOOL = qmake
+endif
+
+#kdevelop: SCRIPT_BUILDTOOL = script
+if include_scriptproject
+SCRIPT_BUILDTOOL = script
+endif
+
+SUBDIRS = lib $(ADA_BUILDTOOL) $(ANT_BUILDTOOL) \
+ $(AUTOTOOLS_BUILDTOOL) $(CUSTOMMAKEFILES_BUILDTOOL) $(PASCAL_BUILDTOOL) \
+ $(QMAKE_BUILDTOOL) $(SCRIPT_BUILDTOOL)
+
+DOXYGEN_EMPTY = YES
+include ../Doxyfile.am