summaryrefslogtreecommitdiffstats
path: root/buildtools/ant/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'buildtools/ant/CMakeLists.txt')
-rw-r--r--buildtools/ant/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/buildtools/ant/CMakeLists.txt b/buildtools/ant/CMakeLists.txt
new file mode 100644
index 00000000..1b7cfd98
--- /dev/null
+++ b/buildtools/ant/CMakeLists.txt
@@ -0,0 +1,40 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/buildtools/lib/base
+ ${CMAKE_SOURCE_DIR}/lib/interfaces
+ ${CMAKE_SOURCE_DIR}/lib/interfaces/extensions
+ ${CMAKE_SOURCE_DIR}/lib/util
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kdevantproject.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES kdevantproject.rc DESTINATION ${DATA_INSTALL_DIR}/kdevantproject )
+
+
+##### libkdevantproject (module) ################
+
+tde_add_kpart( libkdevantproject AUTOMOC
+ SOURCES
+ antprojectpart.cpp antoptionswidget.ui classpathwidget.ui
+ LINK kdevbuildbase-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)