summaryrefslogtreecommitdiffstats
path: root/kdevdesigner/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kdevdesigner/src/Makefile.am')
-rw-r--r--kdevdesigner/src/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/kdevdesigner/src/Makefile.am b/kdevdesigner/src/Makefile.am
new file mode 100644
index 00000000..f6e1b854
--- /dev/null
+++ b/kdevdesigner/src/Makefile.am
@@ -0,0 +1,47 @@
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kdevdesigner.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kdevdesigner.pot
+
+
+# this Makefile creates both a KPart application and a KPart
+#########################################################################
+# APPLICATION SECTION
+#########################################################################
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = kdevdesigner
+
+# the application source, library search path, and link libraries
+kdevdesigner_SOURCES = main.cpp kdevdesigner.cpp
+kdevdesigner_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+kdevdesigner_LDADD = $(LIB_KPARTS)
+
+# this is where the desktop file will go
+#shelldesktopdir = $(kde_appsdir)/Development
+#shelldesktop_DATA = kdevdesigner.desktop
+xdg_apps_DATA = kdevdesigner.desktop
+
+# this is where the shell's XML-GUI resource file goes
+shellrcdir = $(kde_datadir)/kdevdesigner
+shellrc_DATA = kdevdesigner_shell.rc
+
+#########################################################################
+# KPART SECTION
+#########################################################################
+
+# the Part's source, library search path, and link libraries
+
+
+# this is where the desktop file will go
+partdesktopdir = $(kde_servicesdir)
+
+# this is where the part's XML-GUI resource file goes
+partrcdir = $(kde_datadir)/kdevdesignerpart