summaryrefslogtreecommitdiffstats
path: root/languages/ada/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'languages/ada/CMakeLists.txt')
-rw-r--r--languages/ada/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/languages/ada/CMakeLists.txt b/languages/ada/CMakeLists.txt
new file mode 100644
index 00000000..976f6902
--- /dev/null
+++ b/languages/ada/CMakeLists.txt
@@ -0,0 +1,50 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( app_templates )
+add_subdirectory( file_templates )
+add_subdirectory( doc )
+
+# FIXME KDE_CXXFLAGS = $(USE_EXCEPTIONS)
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/lib/interfaces
+ ${CMAKE_SOURCE_DIR}/lib/interfaces/external
+ ${CMAKE_SOURCE_DIR}/lib/util
+ ${CMAKE_SOURCE_DIR}/lib/antlr
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kdevadasupport.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES kdevadasupport.rc DESTINATION ${DATA_INSTALL_DIR}/kdevadasupport )
+
+
+##### libkdevadasupport (module) ################
+
+tde_add_kpart( libkdevadasupport AUTOMOC
+ SOURCES
+ adasupportpart.cpp problemreporter.cpp backgroundparser.cpp
+ addclassdlg.ui addclass.cpp configproblemreporter.ui
+ ada_utils.cpp adasupport.cpp AdaLexer.cpp AdaParser.cpp
+ AdaTreeParserSuper.cpp AdaStoreWalker.cpp
+ LINK antlr-static kdevelop-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)