summaryrefslogtreecommitdiffstats
path: root/languages/cpp/app_templates/cmakesimple/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'languages/cpp/app_templates/cmakesimple/CMakeLists.txt')
-rw-r--r--languages/cpp/app_templates/cmakesimple/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/languages/cpp/app_templates/cmakesimple/CMakeLists.txt b/languages/cpp/app_templates/cmakesimple/CMakeLists.txt
new file mode 100644
index 00000000..c8087165
--- /dev/null
+++ b/languages/cpp/app_templates/cmakesimple/CMakeLists.txt
@@ -0,0 +1,15 @@
+
+PROJECT(%{APPNAMELC})
+
+#if you don't want the full compiler output, remove the following line
+SET(CMAKE_VERBOSE_MAKEFILE ON)
+
+#add definitions, compiler switches, etc.
+ADD_DEFINITIONS(-Wall -O2)
+
+#list all source files here
+ADD_EXECUTABLE(%{APPNAMELC} main.cpp)
+
+#need to link to some other libraries ? just add them here
+#TARGET_LINK_LIBRARIES(%{APPNAMELC} png jpeg)
+