summaryrefslogtreecommitdiffstats
path: root/languages/fortran/compiler/pgioptions/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'languages/fortran/compiler/pgioptions/CMakeLists.txt')
-rw-r--r--languages/fortran/compiler/pgioptions/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/languages/fortran/compiler/pgioptions/CMakeLists.txt b/languages/fortran/compiler/pgioptions/CMakeLists.txt
new file mode 100644
index 00000000..9c2e7f5f
--- /dev/null
+++ b/languages/fortran/compiler/pgioptions/CMakeLists.txt
@@ -0,0 +1,39 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/lib/interfaces
+ ${CMAKE_SOURCE_DIR}/lib/interfaces/extras
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES
+ kdevpghpfoptions.desktop kdevpgf77options.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### libkdevpgioptions (module) ################
+
+tde_add_kpart( libkdevpgioptions AUTOMOC
+ SOURCES
+ pgioptionsfactory.cpp pgioptionsplugin.cpp
+ LINK kdevextras-shared kdeui-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)