summaryrefslogtreecommitdiffstats
path: root/languages/lib/designer_integration/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'languages/lib/designer_integration/CMakeLists.txt')
-rw-r--r--languages/lib/designer_integration/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/languages/lib/designer_integration/CMakeLists.txt b/languages/lib/designer_integration/CMakeLists.txt
new file mode 100644
index 00000000..ca493996
--- /dev/null
+++ b/languages/lib/designer_integration/CMakeLists.txt
@@ -0,0 +1,44 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/lib/interfaces
+ ${CMAKE_SOURCE_DIR}/lib/interfaces/extensions
+ ${CMAKE_SOURCE_DIR}/lib/interfaces/external
+ ${CMAKE_SOURCE_DIR}/lib/util
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ qtdesignerintegration.h implementationwidget.h
+ ${CMAKE_CURRENT_BINARY_DIR}/implementationwidgetbase.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/kdevelop/languages/designer_integration )
+
+
+##### designerintegration (shared) ##############
+
+tde_add_library( designerintegration SHARED AUTOMOC
+ SOURCES
+ implementationwidgetbase.ui implementationwidget.cpp
+ qtdesignerintegration.cpp
+ VERSION 0.0.0
+ LINK kdevelop-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)