summaryrefslogtreecommitdiffstats
path: root/languages/pascal/compiler/fpcoptions/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'languages/pascal/compiler/fpcoptions/CMakeLists.txt')
-rw-r--r--languages/pascal/compiler/fpcoptions/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/languages/pascal/compiler/fpcoptions/CMakeLists.txt b/languages/pascal/compiler/fpcoptions/CMakeLists.txt
new file mode 100644
index 00000000..12c9ef89
--- /dev/null
+++ b/languages/pascal/compiler/fpcoptions/CMakeLists.txt
@@ -0,0 +1,37 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/lib/interfaces
+ ${CMAKE_SOURCE_DIR}/lib/interfaces/extras
+ ${CMAKE_SOURCE_DIR}/lib/widgets
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kdevfpcoptions.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### libkdevfpcoptions (module) ################
+
+tde_add_kpart( libkdevfpcoptions AUTOMOC
+ SOURCES fpcoptionsplugin.cpp optiontabs.cpp
+ LINK kdevwidgets-shared kdevextras-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)