summaryrefslogtreecommitdiffstats
path: root/languages/python/app_templates/pythonhello/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'languages/python/app_templates/pythonhello/Makefile.am')
-rw-r--r--languages/python/app_templates/pythonhello/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/languages/python/app_templates/pythonhello/Makefile.am b/languages/python/app_templates/pythonhello/Makefile.am
new file mode 100644
index 00000000..3d66b1a7
--- /dev/null
+++ b/languages/python/app_templates/pythonhello/Makefile.am
@@ -0,0 +1,15 @@
+dataFiles = app.py app.kdevelop pythonhello.png
+templateName = pythonhello
+### no need to change below:
+template_DATA = $(templateName).kdevtemplate
+templatedir = ${appwizarddatadir}/templates
+
+appwizarddatadir = ${kde_datadir}/kdevappwizard
+$(templateName).tar.gz: ${dataFiles}
+ $(TAR) -cf $(templateName).tar -C $(srcdir) ${dataFiles}
+ $(GZIP_COMMAND) -f9 $(templateName).tar
+
+archivedir = ${appwizarddatadir}
+archive_DATA = $(templateName).tar.gz ${templateName}.png
+
+CLEANFILES = *.tar.gz \ No newline at end of file