summaryrefslogtreecommitdiffstats
path: root/lib/astyle/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/astyle/CMakeLists.txt')
-rw-r--r--lib/astyle/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/lib/astyle/CMakeLists.txt b/lib/astyle/CMakeLists.txt
new file mode 100644
index 00000000..8a0abb9b
--- /dev/null
+++ b/lib/astyle/CMakeLists.txt
@@ -0,0 +1,24 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+##### astyle (static) ###########################
+
+tde_add_library( astyle STATIC_PIC
+ SOURCES
+ ASBeautifier.cpp ASEnhancer.cpp
+ ASFormatter.cpp ASResource.cpp
+)