summaryrefslogtreecommitdiffstats
path: root/lib/widgets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/widgets/CMakeLists.txt')
-rw-r--r--lib/widgets/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/lib/widgets/CMakeLists.txt b/lib/widgets/CMakeLists.txt
new file mode 100644
index 00000000..aae0455b
--- /dev/null
+++ b/lib/widgets/CMakeLists.txt
@@ -0,0 +1,52 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( propeditor )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/lib/interfaces
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ klistviewaction.h qcomboview.h flagboxes.h
+ ksavealldialog.h resizablecombo.h kcomboview.h
+ kdevhtmlpart.h processlinemaker.h processwidget.h
+ fancylistviewitem.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/kdevelop/widgets )
+
+
+##### other data ################################
+
+install( FILES kdevhtml_partui.rc DESTINATION ${DATA_INSTALL_DIR}/kdevelop )
+
+
+##### kdevwidgets (shared) ######################
+
+tde_add_library( kdevwidgets SHARED AUTOMOC
+ SOURCES
+ flagboxes.cpp qcomboview.cpp klistviewaction.cpp
+ kcomboview.cpp resizablecombo.cpp kdevhtmlpart.cpp
+ processlinemaker.cpp processwidget.cpp ksavealldialog.cpp
+ fancylistviewitem.cpp
+ VERSION 0.0.0
+ LINK kio-shared khtml-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)