summaryrefslogtreecommitdiffstats
path: root/parts/astyle/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'parts/astyle/Makefile.am')
-rw-r--r--parts/astyle/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/parts/astyle/Makefile.am b/parts/astyle/Makefile.am
new file mode 100644
index 00000000..dc3712b2
--- /dev/null
+++ b/parts/astyle/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES = -I$(top_srcdir)/lib/astyle -I$(top_srcdir)/lib/interfaces \
+ -I$(top_srcdir)/lib/interfaces/extensions -I$(top_srcdir)/lib/util $(all_includes)
+
+kde_module_LTLIBRARIES = libkdevastyle.la
+libkdevastyle_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkdevastyle_la_LIBADD = $(top_builddir)/lib/libkdevelop.la \
+ $(top_builddir)/lib/astyle/libastyle.la
+
+libkdevastyle_la_SOURCES = astyle_part.cpp astyleconfig.ui astyle_widget.cpp astyle_adaptor.cpp
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = kdevastyle.desktop
+
+rc_DATA = kdevpart_astyle.rc
+rcdir = $(kde_datadir)/kdevastyle