summaryrefslogtreecommitdiffstats
path: root/parts/documentation/interfaces/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'parts/documentation/interfaces/CMakeLists.txt')
-rw-r--r--parts/documentation/interfaces/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/parts/documentation/interfaces/CMakeLists.txt b/parts/documentation/interfaces/CMakeLists.txt
new file mode 100644
index 00000000..8550a5cf
--- /dev/null
+++ b/parts/documentation/interfaces/CMakeLists.txt
@@ -0,0 +1,44 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ kdevdocumentationplugin.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/kdevelop/parts/documentation )
+
+
+##### other data ################################
+
+install( FILES
+ kdevelopdocumentationplugins.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+
+
+##### documentation_interfaces (shared) #########
+
+tde_add_library( documentation_interfaces SHARED AUTOMOC
+ SOURCES kdevdocumentationplugin.cpp
+ VERSION 0.0.0
+ LINK kio-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)