summaryrefslogtreecommitdiffstats
path: root/parts/documentation/plugins/chm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'parts/documentation/plugins/chm/CMakeLists.txt')
-rw-r--r--parts/documentation/plugins/chm/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/parts/documentation/plugins/chm/CMakeLists.txt b/parts/documentation/plugins/chm/CMakeLists.txt
new file mode 100644
index 00000000..d0f18aea
--- /dev/null
+++ b/parts/documentation/plugins/chm/CMakeLists.txt
@@ -0,0 +1,39 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_definitions( ${KDE_PLUGIN} )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/lib/interfaces
+ ${CMAKE_SOURCE_DIR}/lib/util
+ ${CMAKE_SOURCE_DIR}/parts/documentation/interfaces
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES docchmplugin.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### libdocchmplugin (module) ##################
+
+tde_add_kpart( libdocchmplugin AUTOMOC
+ SOURCES docchmplugin.cpp
+ LINK documentation_interfaces-shared kdevelop-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)