summaryrefslogtreecommitdiffstats
path: root/parts/doxygen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'parts/doxygen/Makefile.am')
-rw-r--r--parts/doxygen/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/parts/doxygen/Makefile.am b/parts/doxygen/Makefile.am
new file mode 100644
index 00000000..8682a63d
--- /dev/null
+++ b/parts/doxygen/Makefile.am
@@ -0,0 +1,19 @@
+# Here resides the doxygen part
+
+INCLUDES = -I$(top_srcdir)/lib/interfaces \
+ -I$(top_srcdir)/lib/interfaces/extensions -I$(top_srcdir)/lib/util -I$(top_srcdir)/src -DDOXYWIZARD \
+ $(all_includes)
+
+kde_module_LTLIBRARIES = libkdevdoxygen.la
+libkdevdoxygen_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkdevdoxygen_la_LIBADD = $(top_builddir)/lib/libkdevelop.la
+
+libkdevdoxygen_la_SOURCES = doxygenpart.cpp doxygenconfigwidget.cpp input.cpp config.cpp version.cpp messages.cpp
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = kdevdoxygen.desktop
+
+rcdir = $(kde_datadir)/kdevdoxygen
+rc_DATA = kdevdoxygen.rc