summaryrefslogtreecommitdiffstats
path: root/parts/filecreate/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'parts/filecreate/CMakeLists.txt')
-rw-r--r--parts/filecreate/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/parts/filecreate/CMakeLists.txt b/parts/filecreate/CMakeLists.txt
new file mode 100644
index 00000000..7cc22d04
--- /dev/null
+++ b/parts/filecreate/CMakeLists.txt
@@ -0,0 +1,49 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( file-templates )
+
+add_definitions( ${KDE_PLUGIN} )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/lib/interfaces
+ ${CMAKE_SOURCE_DIR}/lib/interfaces/extensions
+ ${CMAKE_SOURCE_DIR}/lib/util
+ ${CMAKE_SOURCE_DIR}/parts/filecreate
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kdevfilecreate.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES kdevpart_filecreate.rc template-info.xml DESTINATION ${DATA_INSTALL_DIR}/kdevfilecreate )
+
+
+##### libkdevfilecreate (module) ################
+
+tde_add_kpart( libkdevfilecreate AUTOMOC
+ SOURCES
+ filecreate_part.cpp filecreate_listitem.cpp
+ filecreate_filetype.cpp filecreate_filedialog.cpp
+ fcconfigwidgetbase.ui fcconfigwidget.cpp fctypeeditbase.ui
+ fctypeedit.cpp fctemplateeditbase.ui fctemplateedit.cpp
+ filecreate_newfile.cpp
+ LINK kdevelop-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)