summaryrefslogtreecommitdiffstats
path: root/parts/fullscreen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'parts/fullscreen/Makefile.am')
-rw-r--r--parts/fullscreen/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/parts/fullscreen/Makefile.am b/parts/fullscreen/Makefile.am
new file mode 100644
index 00000000..3fecf8e5
--- /dev/null
+++ b/parts/fullscreen/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = -I$(top_srcdir)/lib/interfaces -I$(top_srcdir)/lib/util $(all_includes)
+
+kde_module_LTLIBRARIES = libkdevfullscreen.la
+libkdevfullscreen_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkdevfullscreen_la_LIBADD = $(top_builddir)/lib/libkdevelop.la
+
+libkdevfullscreen_la_SOURCES = fullscreen_part.cpp
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = kdevfullscreen.desktop
+
+rcdir = $(kde_datadir)/kdevfullscreen
+rc_DATA = kdevpart_fullscreen.rc