summaryrefslogtreecommitdiffstats
path: root/parts/konsole/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'parts/konsole/Makefile.am')
-rw-r--r--parts/konsole/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/parts/konsole/Makefile.am b/parts/konsole/Makefile.am
new file mode 100644
index 00000000..b0faabf9
--- /dev/null
+++ b/parts/konsole/Makefile.am
@@ -0,0 +1,16 @@
+# Here resides the konsole view part.
+
+INCLUDES = -I$(top_srcdir)/lib/interfaces -I$(top_srcdir)/lib/util $(all_includes)
+
+kde_module_LTLIBRARIES = libkdevkonsoleview.la
+libkdevkonsoleview_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkdevkonsoleview_la_LIBADD = $(top_builddir)/lib/libkdevelop.la \
+ $(top_builddir)/lib/util/libkdevutil.la
+
+libkdevkonsoleview_la_SOURCES = konsoleviewpart.cpp
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = kdevkonsoleview.desktop
+