summaryrefslogtreecommitdiffstats
path: root/parts/partexplorer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'parts/partexplorer/CMakeLists.txt')
-rw-r--r--parts/partexplorer/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/parts/partexplorer/CMakeLists.txt b/parts/partexplorer/CMakeLists.txt
new file mode 100644
index 00000000..0b3e6a3a
--- /dev/null
+++ b/parts/partexplorer/CMakeLists.txt
@@ -0,0 +1,40 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_definitions( ${KDE_PLUGIN} )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/lib/interfaces
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kdevpartexplorer.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES kdevpartexplorer.rc DESTINATION ${DATA_INSTALL_DIR}/kdevpartexplorer )
+
+
+##### libkdevpartexplorer (module) ##############
+
+tde_add_kpart( libkdevpartexplorer AUTOMOC
+ SOURCES
+ partexplorerformbase.ui partexplorerform.cpp
+ partexplorer_plugin.cpp
+ LINK kdevelop-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)