summaryrefslogtreecommitdiffstats
path: root/parts/replace/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'parts/replace/Makefile.am')
-rw-r--r--parts/replace/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/parts/replace/Makefile.am b/parts/replace/Makefile.am
new file mode 100644
index 00000000..78a7ab4b
--- /dev/null
+++ b/parts/replace/Makefile.am
@@ -0,0 +1,16 @@
+# Here resides the replace part (search and replace in the entire project)
+
+INCLUDES = -I$(top_srcdir)/lib/interfaces -I$(top_srcdir)/lib/util $(all_includes)
+
+kde_module_LTLIBRARIES = libkdevreplace.la
+libkdevreplace_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkdevreplace_la_LIBADD = $(top_builddir)/lib/libkdevelop.la
+libkdevreplace_la_SOURCES = replace_part.cpp replace_widget.cpp replacedlg.ui replaceitem.cpp replaceview.cpp replacedlgimpl.cpp
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = kdevreplace.desktop
+
+rcdir = $(kde_datadir)/kdevreplace
+rc_DATA = kdevpart_replace.rc