summaryrefslogtreecommitdiffstats
path: root/src/profileengine/editor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/profileengine/editor/CMakeLists.txt')
-rw-r--r--src/profileengine/editor/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/profileengine/editor/CMakeLists.txt b/src/profileengine/editor/CMakeLists.txt
new file mode 100644
index 00000000..ddc82809
--- /dev/null
+++ b/src/profileengine/editor/CMakeLists.txt
@@ -0,0 +1,38 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/src/profileengine/lib
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kdevprofileeditor (executable) ############
+
+tde_add_executable( kdevprofileeditor
+ SOURCES main.cpp
+ LINK profileeditor-static profileengine-shared kio-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### profileeditor (static) ####################
+
+tde_add_library( profileeditor STATIC AUTOMOC
+ SOURCES
+ profileeditorbase.ui profileeditor.cpp addprofilewidget.ui
+)