summaryrefslogtreecommitdiffstats
path: root/src/profileengine/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/profileengine/lib/CMakeLists.txt')
-rw-r--r--src/profileengine/lib/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/profileengine/lib/CMakeLists.txt b/src/profileengine/lib/CMakeLists.txt
new file mode 100644
index 00000000..f6cad526
--- /dev/null
+++ b/src/profileengine/lib/CMakeLists.txt
@@ -0,0 +1,37 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_SOURCE_DIR}/lib/interfaces
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ profileengine.h profile.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/kdevelop/shell/profileengine )
+
+
+##### profileengine (shared) ####################
+
+tde_add_library( profileengine SHARED
+ SOURCES profileengine.cpp profile.cpp
+ VERSION 0.0.0
+ LINK kio-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)