summaryrefslogtreecommitdiffstats
path: root/src/tdeconf_update/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tdeconf_update/CMakeLists.txt')
-rw-r--r--src/tdeconf_update/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/tdeconf_update/CMakeLists.txt b/src/tdeconf_update/CMakeLists.txt
new file mode 100644
index 00000000..4b605615
--- /dev/null
+++ b/src/tdeconf_update/CMakeLists.txt
@@ -0,0 +1,32 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kdev-gen-settings.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )
+
+
+##### kdev-gen-settings-tdeconf_update (executable)
+
+tde_add_executable( kdev-gen-settings-tdeconf_update
+ SOURCES kdev-gen-settings-tdeconf_update.cpp
+ LINK ${TQT_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}/tdeconf_update_bin
+)