summaryrefslogtreecommitdiffstats
path: root/tdevdesigner/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdevdesigner/src/Makefile.am')
-rw-r--r--tdevdesigner/src/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/tdevdesigner/src/Makefile.am b/tdevdesigner/src/Makefile.am
new file mode 100644
index 00000000..c88a016d
--- /dev/null
+++ b/tdevdesigner/src/Makefile.am
@@ -0,0 +1,47 @@
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = tdevdesigner.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/tdevdesigner.pot
+
+
+# this Makefile creates both a KPart application and a KPart
+#########################################################################
+# APPLICATION SECTION
+#########################################################################
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = tdevdesigner
+
+# the application source, library search path, and link libraries
+tdevdesigner_SOURCES = main.cpp tdevdesigner.cpp
+tdevdesigner_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
+tdevdesigner_LDADD = $(LIB_TDEPARTS)
+
+# this is where the desktop file will go
+#shelldesktopdir = $(kde_appsdir)/Development
+#shelldesktop_DATA = tdevdesigner.desktop
+xdg_apps_DATA = tdevdesigner.desktop
+
+# this is where the shell's XML-GUI resource file goes
+shellrcdir = $(kde_datadir)/tdevdesigner
+shellrc_DATA = tdevdesigner_shell.rc
+
+#########################################################################
+# KPART SECTION
+#########################################################################
+
+# the Part's source, library search path, and link libraries
+
+
+# this is where the desktop file will go
+partdesktopdir = $(kde_servicesdir)
+
+# this is where the part's XML-GUI resource file goes
+partrcdir = $(kde_datadir)/tdevdesignerpart