summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-06-28 15:14:51 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-03-12 00:35:39 +0100
commiteea71ca9ecdfbd4682054a86cc9bbf954af94693 (patch)
treeec6ffbfad0861bf4195509dfb13845aa4bb17085 /CMakeLists.txt
parent14a52daecece82f3be90c37de2873eb368cbe415 (diff)
downloadtdewebdev-eea71ca9ecdfbd4682054a86cc9bbf954af94693.tar.gz
tdewebdev-eea71ca9ecdfbd4682054a86cc9bbf954af94693.zip
Conversion to the cmake building system.
Delete empty files (dummy.cpp, xsldbgconfig.h). Remove hard-coded path for the kmdr-executor executable. Replaced $TQTDIR/doc/html string path for TQTDOCDIR in kommander. Add man pages taken from the Debian packaging. Signed-off-by: gregory guy <gregory-tde@laposte.net> Fix linking - kxsldbgcommon-static and kimagemapeditorcommon-static needs to be embedded. Move the linking of xml and readline libraries to the appropriate static libraries. Add build option WITH_QUANTA_CVSSERVICE. Add a test whether the readline can be linked standalone or whether ncurses is needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 4c43d1fbb66a296958ed1d0dbddf3f8ac4466130)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt62
1 files changed, 36 insertions, 26 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ef86ed13..68fef180 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,17 +15,17 @@ cmake_minimum_required( VERSION 2.8.12 )
##### general package setup #####################
project( tdewebdev )
+set( VERSION R14.0.10 )
##### include essential cmake modules ###########
+include( FindPkgConfig )
+include( CheckFunctionExists )
+include( CheckIncludeFile )
+include( CheckLibraryExists )
+include( CheckCSourceCompiles )
include( CheckCXXSourceCompiles )
-include( CheckFunctionExists )
-include( CheckIncludeFileCXX )
-include( CheckStructHasMember )
-include( CheckSymbolExists )
-include( CheckTypeSize )
-include( FindPkgConfig )
##### include our cmake modules #################
@@ -40,19 +40,30 @@ include( TDESetupPaths )
tde_setup_paths( )
-##### optional stuff ############################
+##### optional stuff
-# option( WITH_LIBVISUAL "Enable libvisual support" OFF )
-# option( WITH_KONQSIDEBAR "Enable konqsidebar plugin" OFF )
-# option( WITH_XINE "Enable xine-engine support" OFF )
-# option( WITH_LIBGPOD "Enable iPod support from libgpod" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_OTHER_EDITORS "Build with other editors than kate" ${WITH_ALL_OPTIONS} )
+option( WITH_QUANTA_CVSSERVICE "Build quanta with cvs service support" ${WITH_ALL_OPTIONS} )
-##### user requested modules ####################
+##### user requested modules
-option( BUILD_ALL "Build all" OFF )
-option( BUILD_TDEFILEREPLACE "Build tdefilereplace" ${BUILD_ALL} )
-option( BUILD_QUANTA "Build quanta" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_QUANTA "Build quanta" ${BUILD_ALL} )
+option( BUILD_KXSLDBG "Build kxsldbg" ${BUILD_ALL} )
+option( BUILD_KOMMANDER "Build Kommander" ${BUILD_ALL} )
+option( BUILD_KLINKSTATUS "Build klinkstatus" ${BUILD_ALL} )
+option( BUILD_KIMAGEMAPEDITOR "Build kimagemapeditor" ${BUILD_ALL} )
+option( BUILD_TDEFILEREPLACE "Build tdefilereplace" ${BUILD_ALL} )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+
+
+##### user defined options
+
+set( XSLDBG_BIN "xsldbg" CACHE STRING "Name of the xsldbg executable" )
+set( KMDR_EXECUTOR_PATH "${CMAKE_INSTALL_PREFIX}/bin/kmdr-executor" CACHE STRING "Path for the kmdr-executor executable" )
##### configure checks ##########################
@@ -62,24 +73,23 @@ include( ConfigureChecks.cmake )
###### global compiler settings #################
-add_definitions(
- -DHAVE_CONFIG_H
- ${TQT_CFLAGS_OTHER}
-)
+add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST )
-set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -include tqt.h" )
+set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined" )
##### source directories ########################
-if( BUILD_QUANTA )
- add_subdirectory( lib )
-endif( )
-
-tde_conditional_add_subdirectory( BUILD_TDEFILEREPLACE tdefilereplace )
-tde_conditional_add_subdirectory( BUILD_QUANTA quanta )
+tde_conditional_add_subdirectory( BUILD_QUANTA lib )
+tde_conditional_add_subdirectory( BUILD_QUANTA quanta )
+tde_conditional_add_subdirectory( BUILD_KXSLDBG kxsldbg )
+tde_conditional_add_subdirectory( BUILD_KOMMANDER kommander )
+tde_conditional_add_subdirectory( BUILD_KLINKSTATUS klinkstatus )
+tde_conditional_add_subdirectory( BUILD_KIMAGEMAPEDITOR kimagemapeditor )
+tde_conditional_add_subdirectory( BUILD_TDEFILEREPLACE tdefilereplace )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
##### write configure files #####################