summaryrefslogtreecommitdiffstats
path: root/kfilereplace/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commite9ae80694875f869892f13f4fcaf1170a00dea41 (patch)
treeaa2f8d8a217e2d376224c8d46b7397b68d35de2d /kfilereplace/Makefile.am
downloadtdewebdev-e9ae80694875f869892f13f4fcaf1170a00dea41.tar.gz
tdewebdev-e9ae80694875f869892f13f4fcaf1170a00dea41.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdewebdev@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kfilereplace/Makefile.am')
-rw-r--r--kfilereplace/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/kfilereplace/Makefile.am b/kfilereplace/Makefile.am
new file mode 100644
index 00000000..528a791e
--- /dev/null
+++ b/kfilereplace/Makefile.am
@@ -0,0 +1,43 @@
+## Makefile.am for kfilereplace
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# this has all of the subdirectories that make will recurse into. if
+# there are none, comment this out
+SUBDIRS = toolbar
+
+# these are the headers for your project
+noinst_HEADERS = kaddstringdlg.h kfilereplaceiface.h kfilereplacelib.h \
+ knewprojectdlg.h kfilereplaceview.h koptionsdlg.h report.h commandengine.h \
+ configurationclasses.h kfilereplace.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = libkfilereplacepart.la
+libkfilereplacepart_la_SOURCES = kfilereplacepart.cpp kfilereplaceview.cpp \
+ kfilereplaceviewwdg.ui kaddstringdlg.cpp kaddstringdlgs.ui knewprojectdlg.cpp \
+ knewprojectdlgs.ui koptionsdlg.cpp koptionsdlgs.ui kfilereplacelib.cpp report.cpp \
+ commandengine.cpp configurationclasses.cpp
+
+libkfilereplacepart_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+libkfilereplacepart_la_LIBADD = $(LIB_KFILE) $(LIB_KPARTS) $(LIB_KHTML)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/kfilereplace.pot
+
+KDE_ICON = AUTO
+kde_services_DATA = kfilereplacepart.desktop
+xdg_apps_DATA = kfilereplace.desktop
+
+# this is where the XML-GUI resource file goes
+partrcdir = $(kde_datadir)/kfilereplacepart
+partrc_DATA = kfilereplacepartui.rc
+
+shellrcdir = $(kde_datadir)/kfilereplace
+shellrc_DATA = kfilereplaceui.rc
+bin_PROGRAMS = kfilereplace
+kfilereplace_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+kfilereplace_LDADD = $(LIB_KPARTS)
+kfilereplace_SOURCES = kfilereplace.cpp main.cpp