summaryrefslogtreecommitdiffstats
path: root/kommander/pluginmanager/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-06-28 15:14:51 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-03-12 00:35:39 +0100
commiteea71ca9ecdfbd4682054a86cc9bbf954af94693 (patch)
treeec6ffbfad0861bf4195509dfb13845aa4bb17085 /kommander/pluginmanager/CMakeLists.txt
parent14a52daecece82f3be90c37de2873eb368cbe415 (diff)
downloadtdewebdev-eea71ca9ecdfbd4682054a86cc9bbf954af94693.tar.gz
tdewebdev-eea71ca9ecdfbd4682054a86cc9bbf954af94693.zip
Conversion to the cmake building system.
Delete empty files (dummy.cpp, xsldbgconfig.h). Remove hard-coded path for the kmdr-executor executable. Replaced $TQTDIR/doc/html string path for TQTDOCDIR in kommander. Add man pages taken from the Debian packaging. Signed-off-by: gregory guy <gregory-tde@laposte.net> Fix linking - kxsldbgcommon-static and kimagemapeditorcommon-static needs to be embedded. Move the linking of xml and readline libraries to the appropriate static libraries. Add build option WITH_QUANTA_CVSSERVICE. Add a test whether the readline can be linked standalone or whether ncurses is needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 4c43d1fbb66a296958ed1d0dbddf3f8ac4466130)
Diffstat (limited to 'kommander/pluginmanager/CMakeLists.txt')
-rw-r--r--kommander/pluginmanager/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/kommander/pluginmanager/CMakeLists.txt b/kommander/pluginmanager/CMakeLists.txt
new file mode 100644
index 00000000..077dd20b
--- /dev/null
+++ b/kommander/pluginmanager/CMakeLists.txt
@@ -0,0 +1,30 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/kommander/factory
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kmdr-plugins (executable)
+
+tde_add_executable( kmdr-plugins AUTOMOC
+
+ SOURCES
+ main.cpp
+ mainwindow.cpp
+ pluginmanager.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)