summaryrefslogtreecommitdiffstats
path: root/quanta/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commite9ae80694875f869892f13f4fcaf1170a00dea41 (patch)
treeaa2f8d8a217e2d376224c8d46b7397b68d35de2d /quanta/Makefile.am
downloadtdewebdev-e9ae80694875f869892f13f4fcaf1170a00dea41.tar.gz
tdewebdev-e9ae80694875f869892f13f4fcaf1170a00dea41.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdewebdev@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'quanta/Makefile.am')
-rw-r--r--quanta/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/quanta/Makefile.am b/quanta/Makefile.am
new file mode 100644
index 00000000..a56b2bce
--- /dev/null
+++ b/quanta/Makefile.am
@@ -0,0 +1,24 @@
+SUBDIRS = data utility dialogs components parsers treeviews messages plugins parts project src scripts
+
+#extract messages from sources, toolbars, data files and the toplevel lib directory
+messages: rc.cpp
+ find . -name "*.cpp" -print > files ;\
+ find . -name "*.cc" -print >> files ;\
+ find . -name "*.h" -print >> files ;\
+ find ../lib -name "*.h" -print >> files ;\
+ find ../lib -name "*.cpp" -print >> files ;\
+ toolbars=`find . -name "*.toolbar.tgz"`;\
+ for toolbar in $$toolbars; do \
+ tar Oxfz $$toolbar >> extrafiles ; \
+ done ;\
+ cat data/config/actions.rc >> extrafiles; \
+ $(EXTRACTRC) `find . -name "*.ui"` >> rc.cpp ;\
+ $(EXTRACTRC) `find . -name "*.rc"` >> rc.cpp ;\
+ $(EXTRACTRC) `find . -name "*.kmdr"` >> rc.cpp ;\
+ cat data/chars | perl -e 'while(<STDIN>) { chomp ; s/\"/\\\"/ ; print "i18n(\"$$_\");\n"; }' >> rc.cpp ;\
+ $(EXTRACTRC) extrafiles >> rc.cpp ;\
+ cat extrafiles | perl -e 'while(<STDIN>) { if (/\<action .* text="(.*)"/) { print "i18n(\"$$1\");\n"; }}' | sed -e 's/\&amp;/\&/g' >> rc.cpp
+ (cd data && $(PREPARETIPS) >> ../tips.cpp)
+ find . -name "*.tag" -print | xargs cat | perl -e 'while(<STDIN>) { if (/\<tag .* comment="(.*)"/) { print "i18n(\"$$1\");\n"; }}' >> rc.cpp
+ $(XGETTEXT) rc.cpp tips.cpp `cat files` -o $(podir)/quanta.pot
+ rm -f extrafiles tips.cpp files dirs