summaryrefslogtreecommitdiffstats
path: root/quanta/data/toolbars/html/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-01-02 03:39:25 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-01-13 00:44:05 +0100
commit9cb247a1ce61ca26c02f104ec640f9d6a021286f (patch)
tree255630fb1d885cb052af926d5294675120851876 /quanta/data/toolbars/html/Makefile.am
parent5f692d18937536679f2fa7f41766e3b92aeeae8f (diff)
downloadtdewebdev-9cb247a1ce61ca26c02f104ec640f9d6a021286f.tar.gz
tdewebdev-9cb247a1ce61ca26c02f104ec640f9d6a021286f.zip
Quanta: Change Automake rules to make tarballs for toolbars created during building.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 7670bdfd6f573c1358390b187b9d3dc0b181e1c4)
Diffstat (limited to 'quanta/data/toolbars/html/Makefile.am')
-rw-r--r--quanta/data/toolbars/html/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/quanta/data/toolbars/html/Makefile.am b/quanta/data/toolbars/html/Makefile.am
index be14bd30..e50c1452 100644
--- a/quanta/data/toolbars/html/Makefile.am
+++ b/quanta/data/toolbars/html/Makefile.am
@@ -1,2 +1,20 @@
htmltemplatedir = ${quanta_datadir}/toolbars/html
htmltemplate_DATA = forms.toolbar.tgz lists.toolbar.tgz other.toolbar.tgz standard.toolbar.tgz tables.toolbar.tgz style.toolbar.tgz
+
+forms.toolbar.tgz: forms.actions forms.toolbar
+ tar cfz $@ -C $(<D) $(^F)
+
+lists.toolbar.tgz: lists.actions lists.toolbar
+ tar cfz $@ -C $(<D) $(^F)
+
+other.toolbar.tgz: other.actions other.toolbar
+ tar cfz $@ -C $(<D) $(^F)
+
+standard.toolbar.tgz: standard.actions standard.toolbar
+ tar cfz $@ -C $(<D) $(^F)
+
+tables.toolbar.tgz: tables.actions tables.toolbar
+ tar cfz $@ -C $(<D) $(^F)
+
+style.toolbar.tgz: style.actions style.toolbar
+ tar cfz $@ -C $(<D) $(^F)