summaryrefslogtreecommitdiffstats
path: root/quanta/data/toolbars/tagxml/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-01-02 02:27:18 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-01-13 00:44:04 +0100
commit5f692d18937536679f2fa7f41766e3b92aeeae8f (patch)
tree9c693096400dbe3210cb91a5bd19497c5190ba44 /quanta/data/toolbars/tagxml/CMakeLists.txt
parent92326f9e69bb4aee30dd0f088523d293fc0804da (diff)
downloadtdewebdev-5f692d18937536679f2fa7f41766e3b92aeeae8f.tar.gz
tdewebdev-5f692d18937536679f2fa7f41766e3b92aeeae8f.zip
Quanta: Change CMake rules to make tarballs for toolbars created during building.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 8155faa4ac0e5ac5b6e304c68d04a6df25690feb)
Diffstat (limited to 'quanta/data/toolbars/tagxml/CMakeLists.txt')
-rw-r--r--quanta/data/toolbars/tagxml/CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/quanta/data/toolbars/tagxml/CMakeLists.txt b/quanta/data/toolbars/tagxml/CMakeLists.txt
index 0ced778c..e010fa57 100644
--- a/quanta/data/toolbars/tagxml/CMakeLists.txt
+++ b/quanta/data/toolbars/tagxml/CMakeLists.txt
@@ -3,12 +3,24 @@
# (C) 2010-2011 Serghei Amelian
# serghei (DOT) amelian (AT) gmail.com
#
+# (C) 2019 Slávek Banko
+# slavek.banko (AT) axis.cz
+#
# Improvements and feedback are welcome
#
# This file is released under GPL >= 2
#
#################################################
-install( FILES
- tagxml.toolbar.tgz
- DESTINATION ${DATA_INSTALL_DIR}/quanta/toolbars/tagxml )
+
+##### other data ################################
+
+foreach( _toolbar tagxml )
+
+ tde_create_tarball(
+ TARGET ${_toolbar}.toolbar.tgz
+ FILES ${_toolbar}.actions ${_toolbar}.toolbar
+ DESTINATION ${DATA_INSTALL_DIR}/quanta/toolbars/tagxml
+ )
+
+endforeach( )