summaryrefslogtreecommitdiffstats
path: root/quanta/data/toolbars/wml-1-2/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-01-02 03:39:25 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-01-13 00:44:05 +0100
commit9cb247a1ce61ca26c02f104ec640f9d6a021286f (patch)
tree255630fb1d885cb052af926d5294675120851876 /quanta/data/toolbars/wml-1-2/Makefile.am
parent5f692d18937536679f2fa7f41766e3b92aeeae8f (diff)
downloadtdewebdev-9cb247a1ce61ca26c02f104ec640f9d6a021286f.tar.gz
tdewebdev-9cb247a1ce61ca26c02f104ec640f9d6a021286f.zip
Quanta: Change Automake rules to make tarballs for toolbars created during building.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 7670bdfd6f573c1358390b187b9d3dc0b181e1c4)
Diffstat (limited to 'quanta/data/toolbars/wml-1-2/Makefile.am')
-rw-r--r--quanta/data/toolbars/wml-1-2/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/quanta/data/toolbars/wml-1-2/Makefile.am b/quanta/data/toolbars/wml-1-2/Makefile.am
index 93708ec7..58315013 100644
--- a/quanta/data/toolbars/wml-1-2/Makefile.am
+++ b/quanta/data/toolbars/wml-1-2/Makefile.am
@@ -1,2 +1,20 @@
wmldir = ${quanta_datadir}/toolbars/wml-1-2
wml_DATA = deck.toolbar.tgz forms.toolbar.tgz misc.toolbar.tgz table.toolbar.tgz tasks.toolbar.tgz text.toolbar.tgz
+
+deck.toolbar.tgz: deck.actions deck.toolbar
+ tar cfz $@ -C $(<D) $(^F)
+
+forms.toolbar.tgz: forms.actions forms.toolbar
+ tar cfz $@ -C $(<D) $(^F)
+
+misc.toolbar.tgz: misc.actions misc.toolbar
+ tar cfz $@ -C $(<D) $(^F)
+
+table.toolbar.tgz: table.actions table.toolbar
+ tar cfz $@ -C $(<D) $(^F)
+
+tasks.toolbar.tgz: tasks.actions tasks.toolbar
+ tar cfz $@ -C $(<D) $(^F)
+
+text.toolbar.tgz: text.actions text.toolbar
+ tar cfz $@ -C $(<D) $(^F)