summaryrefslogtreecommitdiffstats
path: root/kommander/factory/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kommander/factory/Makefile.am')
-rw-r--r--kommander/factory/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/kommander/factory/Makefile.am b/kommander/factory/Makefile.am
new file mode 100644
index 00000000..60eb0e6d
--- /dev/null
+++ b/kommander/factory/Makefile.am
@@ -0,0 +1,16 @@
+noinst_LTLIBRARIES = libkommanderfactory.la
+
+# set the include path for X, qt and KDE
+AM_CPPFLAGS = -I$(top_srcdir)/kommander/widget -I$(top_srcdir)/kommander/plugin $(all_includes)
+
+# the library search path.
+libkommanderfactory_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) -no-undefined
+libkommanderfactory_la_LIBADD = $(top_builddir)/kommander/plugin/libkommanderplugin.la
+
+# which sources should be compiled for factory
+libkommanderfactory_la_SOURCES = kommanderfactory.cpp domtool.cpp
+include_HEADERS = kommanderfactory.h
+noinst_HEADERS = domtool.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO