summaryrefslogtreecommitdiffstats
path: root/kommander/plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kommander/plugin/Makefile.am')
-rw-r--r--kommander/plugin/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kommander/plugin/Makefile.am b/kommander/plugin/Makefile.am
new file mode 100644
index 00000000..be1bb9f4
--- /dev/null
+++ b/kommander/plugin/Makefile.am
@@ -0,0 +1,17 @@
+lib_LTLIBRARIES = libkommanderplugin.la
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(top_srcdir)/kommander/widget $(all_includes)
+
+# the library search path.
+libkommanderplugin_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) -no-undefined
+
+# the libraries to link against.
+libkommanderplugin_la_LIBADD = $(LIB_KDEUI) $(LIB_QT)
+
+libkommanderplugin_la_SOURCES = kommanderplugin.cpp specialinformation.cpp
+
+include_HEADERS = kommanderplugin.h specials.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO