summaryrefslogtreecommitdiffstats
path: root/quanta/components/framewizard/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'quanta/components/framewizard/CMakeLists.txt')
-rw-r--r--quanta/components/framewizard/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/quanta/components/framewizard/CMakeLists.txt b/quanta/components/framewizard/CMakeLists.txt
new file mode 100644
index 00000000..0a1f83a1
--- /dev/null
+++ b/quanta/components/framewizard/CMakeLists.txt
@@ -0,0 +1,31 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/lib
+ ${CMAKE_SOURCE_DIR}/quanta/project
+ ${CMAKE_SOURCE_DIR}/quanta/components/framewizard
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+##### framewizard (static) ######################
+
+tde_add_library( framewizard STATIC_PIC AUTOMOC
+ SOURCES
+ fmfpeditors.ui fmrceditors.ui framewizards.ui
+ fwglobal.cpp areaattributedb.cpp
+ selectablearea.cpp treenode.cpp
+ visualframeeditor.cpp fmfpeditor.cpp
+ fmrceditor.cpp framewizard.cpp
+)