summaryrefslogtreecommitdiffstats
path: root/quanta/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'quanta/src/CMakeLists.txt')
-rw-r--r--quanta/src/CMakeLists.txt27
1 files changed, 17 insertions, 10 deletions
diff --git a/quanta/src/CMakeLists.txt b/quanta/src/CMakeLists.txt
index ff7d5d4c..dfd385f1 100644
--- a/quanta/src/CMakeLists.txt
+++ b/quanta/src/CMakeLists.txt
@@ -19,6 +19,7 @@ include_directories(
${CMAKE_BINARY_DIR}/quanta/components/tableeditor
${CMAKE_BINARY_DIR}/quanta/components/csseditor
${CMAKE_BINARY_DIR}/quanta/components/framewizard
+ ${CMAKE_BINARY_DIR}/quanta/components/cvsservice
${CMAKE_SOURCE_DIR}/lib
${CMAKE_SOURCE_DIR}/quanta/src
${CMAKE_SOURCE_DIR}/quanta/project
@@ -31,6 +32,7 @@ include_directories(
${CMAKE_SOURCE_DIR}/quanta/components/tableeditor
${CMAKE_SOURCE_DIR}/quanta/components/csseditor
${CMAKE_SOURCE_DIR}/quanta/components/framewizard
+ ${CMAKE_SOURCE_DIR}/quanta/components/cvsservice
${CMAKE_SOURCE_DIR}/quanta/messages
${CMAKE_SOURCE_DIR}/quanta/treeviews
${CMAKE_SOURCE_DIR}/quanta/plugins
@@ -57,6 +59,7 @@ install( FILES x-webprj.desktop DESTINATION ${MIME_INSTALL_DIR}/application )
set_property( SOURCE kqapp.cpp APPEND PROPERTY COMPILE_DEFINITIONS PREFIX="${CMAKE_INSTALL_PREFIX}" )
tde_add_executable( quanta AUTOMOC
+
SOURCES
quanta_init.cpp quantaview.cpp quantadoc.cpp
main.cpp document.cpp kqapp.cpp quanta.cpp
@@ -64,15 +67,19 @@ tde_add_executable( quanta AUTOMOC
dcopquantaif.skel dcopsettings.cpp dtds.cpp
dcopquanta.cpp viewmanager.cpp
LINK
- project-static plugins-static parser-static
- dtdparser-static treeviews-static dialogs-static
- debuggermanager-static tagdialogs-static
- settingsdialogs-static messages-static
- framewizard-static csseditor-static
- tableeditor-static preview-static
- utility-static quantamodule-static
- kafkalibrary-static tdemdi-shared tdehtml-shared
- tdenewstuff-shared tdeabc-shared tdetexteditor-shared
- ${LIBXML_LIBRARIES} ${LIBXSLT_LIBRARIES}
+ tdecore-shared tdeui-shared tdeio-shared
+ katepartinterfaces-shared tdenewstuff-shared
+ tdeabc-shared tdetexteditor-shared
+ tdemdi-shared tdehtml-shared tdespell-shared
+ kafkalibrary-static project-static
+ plugins-static parser-static
+ dtdparser-static treeviews-static
+ dialogs-static debuggermanager-static
+ tagdialogs-static settingsdialogs-static
+ messages-static framewizard-static
+ csseditor-static tableeditor-static
+ preview-static utility-static quantamodule-static
+ ${LIBXML_LIBRARIES} ${LIBXSLT_LIBRARIES} ${CVSSERVICE_LIBRARIES}
+
DESTINATION ${BIN_INSTALL_DIR}
)