summaryrefslogtreecommitdiffstats
path: root/tdefilereplace/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdefilereplace/CMakeLists.txt')
-rw-r--r--tdefilereplace/CMakeLists.txt56
1 files changed, 0 insertions, 56 deletions
diff --git a/tdefilereplace/CMakeLists.txt b/tdefilereplace/CMakeLists.txt
deleted file mode 100644
index 621c0e02..00000000
--- a/tdefilereplace/CMakeLists.txt
+++ /dev/null
@@ -1,56 +0,0 @@
-#################################################
-#
-# (C) 2010-2011 Serghei Amelian
-# serghei (DOT) amelian (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
-
-add_subdirectory( toolbar )
-
-include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_BINARY_DIR}
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
-)
-
-link_directories(
- ${TQT_LIBRARY_DIRS}
-)
-
-
-##### other data ################################
-
-tde_install_icons( )
-install( FILES tdefilereplace.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES tdefilereplacepart.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
-install( FILES tdefilereplacepartui.rc DESTINATION ${DATA_INSTALL_DIR}/tdefilereplacepart )
-install( FILES tdefilereplaceui.rc DESTINATION ${DATA_INSTALL_DIR}/tdefilereplace )
-
-
-##### libtdefilereplacepart (module) ##############
-
-tde_add_kpart( libtdefilereplacepart AUTOMOC
- SOURCES
- commandengine.cpp configurationclasses.cpp
- tdefilereplacepart.cpp tdefilereplaceview.cpp
- tdefilereplaceviewwdg.ui kaddstringdlg.cpp kaddstringdlgs.ui
- knewprojectdlg.cpp knewprojectdlgs.ui koptionsdlg.cpp
- koptionsdlgs.ui tdefilereplacelib.cpp report.cpp
- LINK tdeio-shared tdeparts-shared
- DESTINATION ${PLUGIN_INSTALL_DIR}
-)
-
-
-##### tdefilereplace (executable) #################
-
-tde_add_executable( tdefilereplace AUTOMOC
- SOURCES
- tdefilereplace.cpp main.cpp
- LINK tdeio-shared tdeparts-shared
- DESTINATION ${BIN_INSTALL_DIR}
-)