summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-12-10 22:23:56 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-12-10 22:24:14 +0100
commit21419a4c58e82acc9c6039c6546d1fe068529eb0 (patch)
treeebb22fe4d021e11ea2c5cf7b44721eec530e76dd /CMakeLists.txt
parent97208d6dbb3b1c4dd4ed77e5d282e408dbeb85bd (diff)
downloadtdmtheme-21419a4c58e82acc9c6039c6546d1fe068529eb0.tar.gz
tdmtheme-21419a4c58e82acc9c6039c6546d1fe068529eb0.zip
Add CMakeL10n rules.
Create translation template. Add CMake rules to build translations. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit a037fdbd50cfe5a0aaeae5d9c498dbaae9f9c930)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cb989be..541754d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,8 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
option( BUILD_ALL "Build all" ON )
option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
##### configure checks
@@ -67,6 +69,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
add_subdirectory( src )
tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
##### write configure files